解决koolshare版LEDE下N2N无法运行的问题

Linux, 折腾 2019/06/17

擦,不得不吐槽,koolshare版的LEDE问题多的要命。

即便确保所有参数都正确,WEB端依然提示所有进程未运行

怀疑是不是命令行写的有问题,去到SSH下手动执行edge命令行

edge -h

报错!

Error loading shared library libcrypto.so.1.0.0: No such file or directory (needed by /koolshare/bin/edge)

好吧,大意就是共享库文件 libcrypto.so.1.0.0 找不到。

翻遍OpenWRT几个共享库的存放路径,在/usr/lib64下找到了它

只不过库名称为libcrypto.so.1.1,并非libcrypto.so.1.0.0

暴力复制并更名大法:

cp /usr/lib64/libcrypto.so.1.1 /usr/lib64/libcrypto.so.1.0.0

成功解决

本文标签:


评论(*号为必填项)